AudioExpert

Das Forum zu AudioExpert - Wegen der DSGVO nur noch lesend...
Aktuelle Zeit: Mo 20. Mai 2019, 10:02

Alle Zeiten sind UTC + 1 Stunde


Forumsregeln


WICHTIGER HINWEIS
==============
Wegen der DSGVO ist das Forum deaktiviert. Es ist keine Registrierung möglich. Alle bestehenden Accounts wurden zurückgesetzt. Alle personenbezogenen Daten wurden gelöscht.
Fragen können gerne per Mail an info [at] udse [.] de geschickt werden, ich erstelle dann ggf. einen Eintrag hier.



Forum gesperrt Dieses Thema ist gesperrt. Du kannst keine Beiträge editieren oder weitere Antworten erstellen.  [ 11 Beiträge ]  Gehe zu Seite 1, 2  Nächste
Autor Nachricht
 Betreff des Beitrags: Problem beim Einlesen [gelöst]
BeitragVerfasst: Mi 18. Aug 2010, 20:59 
Offline

Registriert: Mi 18. Aug 2010, 20:42
Beiträge: 6
Hallo,

leider konnte ich die Funktionen des Programms noch nicht nutzen, da ich meine Musiksammlung gar nicht erst eingelesen bekomme.
Entweder mache ich etwas falsch, oder das Programm hat eine Macke, was ich nicht hoffe, denn es bietet mir genau die Funktionen, nach denen ich schon lange gesucht habe.

Hier einmal meine Konfiguration:

Notebook mit 4 GB Ram, Quadcore Prozessor 2GHz
Windows 7 Ultimate 64 Bit

Meine Musikdaten liegen auf einem NAS QNAP 809pro mit 8TB Plattenplatz. (1,3 TB free)

Ich habe 3 verschiedene Musikverzeichnisse, die ich jetzt eigentlich zu einer Sammlung vereinen möchte.
In meinem Standard Musikverzeichnis liegen 38.340 Dateien in 12.858 Ordnern (Größe: 182 GB)

DIESE SAMMLUNG BEKOMME ICH SCHON NICHT EINGELESEN !

Die 2. Musiksammlung liegt ebenfalls auf den NAS und hat 71.895 Dateien in 4.479 Ordnern (Größe: 346 GB)
Das Verzeichnis habe ich noch gar nicht versucht.

Also ich bekomme, wenn ich Glück habe, eine Fehlermeldung, dass zu wenig Arbeitsspeicher zur Verfügung steht ! ??
Ansonsten höre ich nur ein Piep und das Programm verabschiedet sich.

Es wäre zu schade, wenn dass Programm mit so großen Sammlungen nicht zurecht kommt.

Im Anhang noch ein Beispiel, eines Versuchs zum Einlesen.

Gruß Peter

PS. Anhänge .DOC nicht erlaubt, schade, also kein Beispiel

Nachtrag: ich habe die erste Musiksammlung auch schon auf eine externe Festplatte kopiert und es von dort aus versucht, klappt auch nicht.
Nachtrag2: ich habe NUR MP3 Files


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 09:37 
Offline

Registriert: Mi 14. Jan 2009, 15:11
Beiträge: 770
Hallo Peter,

das klingt sehr seltsam... Also fest steht, dass das Programm an sich durchaus mit solchen Datenmengen umgehen kann, an der bloßen Menge dürfte es also nicht liegen.
Wann genau stürzt das Programm ab:

Es kommt ja zuerst eine Meldung "Verfügbare Dateien werden ermittelt, bitte warten" woraufhin AudioExpert zunächst nur die Verzeichnisstruktur abklappert um festzustellen, wieviele Dateien denn überhaupt angefasst werden müssen.
Danach kommt die Meldung "Dateien werden importiert...". Erst jetzt werden die Dateien wirklich angefasst.

Kommt der Absturz im ersten oder im zweiten Schritt?
(Screenshot übrigens gerne direkt an info<at>udse.de)

Es könnte (sofern der Absturz im zweiten Schritt auftritt) sein, dass in dem zu importierenden Ordner Dateien liegen, die aus irgend einem Grund nicht eingelesen werden können. So könnte z.B. eine riesengroße Datei zu diesem Fehler führen, sofern die Option "MD5-Summe berechnen" aktiviert ist. Ich habe zwar schon eine Begrenzung eingebaut (ich meine, Dateien über 2 GB werden nicht eingelesen, aber selbst 2GB können ja potenziell ein Arbeitsspeicherproblem darstellen)...

Es könnte evtl. Sinn machen, das erweiterte Logging einzuschalten. Das geht über das Menü "Extras | Datenbanktools | Logging einschalten". Daraufhin wird eine Logdatei im Ordner
C:\Users\<Benutzername>\AppData\Roaming\AudioXP
angelegt. D.h. Den Versuch könnten wir noch machen, in der Hoffnung, dass ich so zumindest die Stelle lokalisieren kann.

Ich würde aber im ersten Schritt mal nach "riesigen" Dateien Ausschau halten, das klingt im Moment für mich am plausibelsten!

Viele Grüße
Ulrich


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 17:50 
Offline

Registriert: Mi 18. Aug 2010, 20:42
Beiträge: 6
Hallo Ulrich,

vielen lieben Dank erst mal für die prompte Antwort, schön zu wissen, dass es noch Softwareentwickler gibt, die sich um Probleme kümmern.
(Das schreibe ich extra, weil ich in meiner 30-jährigen IT Erfahrung auch vieles Andere (in puncto Service) erfahren durfte)

So nun wieder zu meinem Problem: (Screenshots reiche ich auch noch nach):

Der erste Lauf wo die Dateien ermittelt werden läuft einwandfrei und auch sehr zügig (sogar über mein LAN) ab.
Der 2. Lauf scheint das Problem zu sein. Ich checke jetzt als erstes mal, ob da irgendwo ein so dicker "Hund"; also große Datei sein kann. Glaube ich aber nicht, da unter Windows mit dem Realplayer SP keine Probleme beim Einlesen und verwalten auftreten. Ich benutze nun seit gut 4 Wochen das "geniale" Musikprogramm Guayadeque unter Linux Mint 9 zum Abspielen. Auch da gibt es beim einlesen in die Datenbank keinerlei Probleme.

Im nächsten Post, der heute noch folgt, werde ich die Log-Datei anhängen, oder auch per Mail senden.
Ich muss nur leider immer zwischen Windows und Linux wechseln, da ich unter Windows kein Mailprogramm mehr installiert habe.

Das Problem wird sicherlich zu lösen sein.

Bis später und
Gruß Peter


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 18:11 
Offline

Registriert: Mi 14. Jan 2009, 15:11
Beiträge: 770
Alles klar, ich stehe hier "Gewehr bei Fuß" - das Problem muss sich doch lösen lassen :-)


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 19:07 
Offline

Registriert: Mi 18. Aug 2010, 20:42
Beiträge: 6
Hi Ulrich,

da bin ich wieder, die Doku was ich gemacht habe, als DOC File und die Logdateien als ZIP gehen jetzt per Mail raus.

In der Zeit mache ich jetzt noch mal den Test mit der USB-Festplatte und nicht über das LAN, dann kommt mit Sicherheit der Speicherfehler.
In der Zwischenzeit, kannst du ja schon mal anschauen, was ich dir gesendet habe.

LG Peter


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 19:54 
Offline

Registriert: Mi 14. Jan 2009, 15:11
Beiträge: 770
Hallo Peter,

nur kurz als Zwischenstand: Habe die Mail erhalten (danke für die tolle Doku!) und bin auf der Suche nach der Ursache.

Wirklich spannend ist ja, dass er nach der 2153ten neuen Datei offensichtlich völlig aus dem Tritt gerät und nichts mehr tut.

In dem Ordner "C:\Users\Peter\AppData\Roaming\AudioXP\Reports" werden noch ein paar Log-Dateien abgelegt.
In der "*_success.html" sind alle erfolgreich importierten Dateien. Da könnte man herausbekommen, welches denn die letzte Datei war, die er importieren konnte.
An dieser (oder derjenigen, die danach hätte importiert werden müssen) *könnte* evtl. irgend etwas faul sein.

Falls Du aus diesen Logs nicht schlau wirst, schick' sie mir doch einfach per Mail.

Es wäre jedenfalls sehr interessant, was das denn für Dateien sind, die zuletzt bearbeitet wurden. Evtl. ist an denen irgend etwas "anders"?

Bis Später,
Ulrich


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 20:19 
Offline

Registriert: Mi 18. Aug 2010, 20:42
Beiträge: 6
Sorry, musste gerade mal was essen ^

Die Dateien bekommst du sofort per Mail UND ich schau auch mal, ob ich schlau draus werde.
Hab ja selber 16 Jahre Programmiererfahrung, auch wenn es lange her ist...

LG Peter


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 21:31 
Offline

Registriert: Mi 14. Jan 2009, 15:11
Beiträge: 770
So, habe Dir gerade eine Mail geschrieben und auch eine neue Version gebaut. Der Download-Link ist noch derselbe wie in der Bestätigungsmail (den mag ich hier nicht posten :-)
Vielleicht bringt das ja den Durchbruch...


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 21:38 
Offline

Registriert: Mi 18. Aug 2010, 20:42
Beiträge: 6
Hi Ulrich,

Mail angekommen, vielen lieben Dank.
Ich habe aber wahrscheinlich zeitgleich auch eine Mail an Dich gesendet.

Eventuell, das überprüfe ich gerade ist das ein typischer Error 53 "Fehler sitzt vor der Tastatur"
Fehlerbehebungs-Code 1: "Change User".

Genaueres in der Mail.

LG Peter


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problem beim Einlesen
BeitragVerfasst: Do 19. Aug 2010, 21:45 
Offline

Registriert: Mi 18. Aug 2010, 20:42
Beiträge: 6
Hi Ulrich,

jetzt habe ich noch eine ganz banale Frage.

Ich hab mir mal das Video auf Youtube angeschaut und da waren die Verzeichnisse am Ende so sortiert:

A
..Abba
..AC/DC
B
..BAP

usw.

Meine Sammlungen sind alle so Sortiert:

Gruppe (oder Interpret)
..CD
....01 Titel
....02 Titel

usw.

Ist das mit AudioExpert auch so machbar ?

Hintergrund ist der, dass ich einen CD Ripper verwende, der genau diese Ordnerstruktur anlegt.

LG Peter


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Forum gesperrt Dieses Thema ist gesperrt. Du kannst keine Beiträge editieren oder weitere Antworten erstellen.  [ 11 Beiträge ]  Gehe zu Seite 1, 2  Nächste

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de